Forum Ametys

Forum de la communauté Ametys

You are not logged in.

#1 15/10/2013 18:57:47

mcdons
Guest
Registered: 15/10/2013
Posts: 11

Empty Config Error Codes

I am having problems installing Ametys CMS on my test/proof of concept environment. The error happens when I try to submit my configuration settings on the first run of the CMS, but there is no associated error code/message with the error pop-up so I have no idea what is wrong with my setup/configuration. Is there a log file or something of the sort that I can examine to see what specifically is wrong with my particular configuration settings?

A second question I have is if it is even possible to install Ametys CMS within the environment that I am using:
Linux Ubuntu 12.4.3_i386 (32 bit) (on a VM for test purposes right now)
Java JDK 7_40
Apache Tomcat 7.0.42
MySQL 5.5.32
MySQL Connector J 5.1.26
Modern Browser (FF or Chrome, most recent version, or IE10)

I require the use of a Linux OS and Apache Tomcat 7.x and running the CMS on a modern FF or Chrome or IE10. The DB and JDBC driver used can be changed if they are incompatible.

Offline

#2 15/10/2013 21:50:24

Cédric Damioli
Ametys Product Manager
From: Toulouse
Registered: 10/08/2010
Posts: 293

Re: Empty Config Error Codes

Hi,

My first guess is that you're having a filesystem rights issue.
Could it be that you're using the Ubuntu-packaged Tomcat 7 (process run as "tomcat7") and the application unzipped as another user (probably yours) in a directory where "tomcat7" does not have any write access ?
If so, there's two main solutions : either don't use the packaged Tomcat, but an unzipped Tomcat run with the same user than Ametys files, or give the Ametys files a write access to the user running Tomcat.

The environment you describe is perfectly suited to run Ametys, and actually probably the most used in production.

When write access is allowed, a log file is output in the WEB-INF/logs directory of the application

Regards,
Cédric

Offline

#3 16/10/2013 21:49:20

mcdons
Guest
Registered: 15/10/2013
Posts: 11

Re: Empty Config Error Codes

Thank you for the response and the direction towards permissions being the issue. I have thus fixed my file permissions by:
Putting my tomcat7 user, generated by apt-get install tomcat7, and the user that ametys is run on (my user) in the same group and gave that group write permissions, recursively, for the $CATALINA_HOME/webapps directory.

Now I have worked through a few of the config issues, correct variable names and more access issues, with the help of the log file's Java stack traces and various online resources including the source to jackrabbit and ametys itself.

I got the site up and running and am now having a problem with creating a user from the administrator area under users management, url:"localhost:8080/cms/_admin/_plugins/core/users/view.html". The error is a com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException with description "Unknown column 'password' in 'field list'".

When I checked out the MySQL tables created by running all of the .sql scripts located in cms/WEB-INF/scripts/mysql I found the user table but it didn't have a password field. I couldn't find any logical place where it would put the password for a user actually. I was wondering if I shouldn't have ran all the .sql scripts but should have picked particular ones to run instead because there are several that appear to be similar and I remember running into a post someone made about asking which ones to run and the response was not to run them all but just some particular ones. However every guide I have found online showed to just run them all and they didn't appear to have issues.

Could you shed light on my problem and what scripts I should run and which ones maybe I shouldn't? I am using default authentication from ametys not doing anything special with user auth such as 3rd person software, etc.

Offline

#4 16/10/2013 22:03:34

mcdons
Guest
Registered: 15/10/2013
Posts: 11

Re: Empty Config Error Codes

I did discover that I should have been using on some of the scripts, the jdbc_users_auth.sql and the jdbc_fousers_auth.sql so long as I am not doing 3rd party authorization, the sql scripts differ from their non "_auth.sql" counterparts by just the 'password' field.

I dropped the 'Users' and the 'FOUsers' tables and ran the "_auth.sql" versions of the two scripts and it solved my problem. I am currently not having any issues with the CMS.

Thank you for the help and I will not hesitate to post on here again if I run into more problems.

Last edited by mcdons (16/10/2013 22:24:56)

Offline

#5 17/10/2013 09:48:14

Raphaël Franchet
Expert Team
From: Toulouse
Registered: 10/08/2010
Posts: 1,091

Re: Empty Config Error Codes

Yes you are right.
There are two scripts for the Users table, because it does exist different UsersManagers in Ametys.

Most UsersAmetys will require a User table with password, but if your are connecting with a SSO, the user table will not require it.


Raphael Franchet
Expert Ametys

Offline

Board footer

Powered by FluxBB