Forum Ametys

Forum de la communauté Ametys

You are not logged in.

#1 10/07/2014 09:34:19

Gino3008
Guest
Registered: 10/07/2014
Posts: 5

Problème back-office

Bonjour la communauté Ametys.
Voila je m'explique je suis en train d'installer Ametys ( 3.5.0 pour info ) sur ma machine.
C'est un Ubuntu LTS 14.04 64bits tournant sous vSphere avec 8 gb de ram dédiée.

J'ai installé Tomcat7, Apache2, JVM, Mysql ( et même Phpmyadmin pour le fun ), le tout en ligne de commande.
Pour l'instant je ne veux le faire tourner qu'en local a simple titre de test. Le back et le front office seront sur la même machine.
Je n'en suis qu'au back-office pour le moment et j'ai suivi la doc d'installation qui se trouve dans le wiki. J'ai donc laissé tomcat sous le port 8080 d'origine et idem pour apache en 80. Tout a l'air de tourner, je me logue en local sur ma page apache, j'ai it works, idem pour tomcat, j'ai créé le user admin pour le manager gui toussa toussa.
Mais lorsque je me logue en Monserveur:80/cms/_admin je tombe sur un not found. Et si j'essaie la même en faisant appel a tomcat Monserveur:8080/cms/_admin j'ai carrément une page blanche, vierge, sans rien dutout.

Concernant les logs dans Catalina.out par exemple j'ai :


juil. 09, 2014 4:27:13 PM org.apache.coyote.AbstractProtocol pause
Infos: Pausing ProtocolHandler [

Offline

#2 10/07/2014 09:49:48

Gino3008
Guest
Registered: 10/07/2014
Posts: 5

Re: Problème back-office

Concernant les logs dans Catalina.out par exemple j'ai :


juil. 09, 2014 4:27:13 PM org.apache.coyote.AbstractProtocol pause
Infos: Pausing ProtocolHandler ["http-bio-8080"]
juil. 09, 2014 4:27:13 PM org.apache.catalina.core.StandardService stopInternal
Infos: Arrêt du service Catalina
juil. 09, 2014 4:27:13 PM org.apache.coyote.AbstractProtocol stop
Infos: Stopping ProtocolHandler ["http-bio-8080"]
juil. 09, 2014 4:27:13 PM org.apache.coyote.AbstractProtocol destroy
Infos: Destroying ProtocolHandler ["http-bio-8080"]
juil. 09, 2014 4:27:38 PM org.apache.catalina.startup.ClassLoaderFactory validateFile
Avertissement: Problem with directory [/usr/share/tomcat7/common/classes], exists: [false], isDirectory: [false], canRead: [false]
juil. 09, 2014 4:27:38 PM org.apache.catalina.startup.ClassLoaderFactory validateFile
Avertissement: Problem with directory [/usr/share/tomcat7/common], exists: [false], isDirectory: [false], canRead: [false]
juil. 09, 2014 4:27:38 PM org.apache.catalina.startup.ClassLoaderFactory validateFile
Avertissement: Problem with directory [/usr/share/tomcat7/server/classes], exists: [false], isDirectory: [false], canRead: [false]
juil. 09, 2014 4:27:38 PM org.apache.catalina.startup.ClassLoaderFactory validateFile
Avertissement: Problem with directory [/usr/share/tomcat7/server], exists: [false], isDirectory: [false], canRead: [false]
juil. 09, 2014 4:27:38 PM org.apache.catalina.startup.ClassLoaderFactory validateFile
Avertissement: Problem with directory [/usr/share/tomcat7/shared/classes], exists: [false], isDirectory: [false], canRead: [false]
juil. 09, 2014 4:27:38 PM org.apache.catalina.startup.ClassLoaderFactory validateFile
Avertissement: Problem with directory [/usr/share/tomcat7/shared], exists: [false], isDirectory: [false], canRead: [false]
juil. 09, 2014 4:27:40 PM org.apache.coyote.AbstractProtocol init
Infos: Initializing ProtocolHandler ["http-bio-8080"]
juil. 09, 2014 4:27:40 PM org.apache.catalina.startup.Catalina load
Infos: Initialization processed in 1740 ms
juil. 09, 2014 4:27:40 PM org.apache.catalina.core.StandardService startInternal
Infos: Démarrage du service Catalina
juil. 09, 2014 4:27:40 PM org.apache.catalina.core.StandardEngine startInternal
Infos: Starting Servlet Engine: Apache Tomcat/7.0.52 (Ubuntu)


Je comprends bien que j'ai un soucis dans mes répertoires mais je ne sais pas comment y remédier.
Est-ce que cela est déjà arrivé à quelqu'un ? Une âme charitable parmis les monstres de Linux ??  big_smile

Offline

#3 10/07/2014 09:49:53

Raphaël Franchet
Expert Team
From: Toulouse
Registered: 10/08/2010
Posts: 1,091

Re: Problème back-office

Bonjour

Les logs ont été tronqués... pouvez-vous les mettre en pièce jointe plutôt ?

Un répertoire "logs" a-t-il été créé dans cms/WEB-INF ?


Raphael Franchet
Expert Ametys

Offline

#4 10/07/2014 09:51:25

Raphaël Franchet
Expert Team
From: Toulouse
Registered: 10/08/2010
Posts: 1,091

Re: Problème back-office

mid-air collision smile

Donc dans vos logs je ne vois pas d'instruction comme quoi "cms" a été déployé.
Comment avez-vous mis l'application dans tomcat ?
- répertoire webapps ?
- cms.xml dans la conf ?


Raphael Franchet
Expert Ametys

Offline

#5 10/07/2014 10:06:40

Gino3008
Guest
Registered: 10/07/2014
Posts: 5

Re: Problème back-office

J'ai simplement dezippé la derniere version d'Ametys dans /home/cms/Ametys_CMS/application/tmp/v1_0_0/ comme préconisé dans le tuto.
Puis j'ai fait les liens site et cms. C'est tout.
Ca me paraissais un peu limite d'avoir fait que ça je vous l'accorde mais j'ai rien trouvé d'autre.

Concernant webapps j'ai ça dedans ( piece jointe )

mini_344980Sanstitre.png

Last edited by Gino3008 (10/07/2014 10:07:22)

Offline

#6 10/07/2014 10:22:51

Raphaël Franchet
Expert Team
From: Toulouse
Registered: 10/08/2010
Posts: 1,091

Re: Problème back-office

le /tmp/ en moins et ça sera parfait pour le répertoire d'installation

ensuite, soit dans le répertoire webapps vous faites un lien symbolique, soit dans tomcat/conf/Catalina/localhost vous ajoutez un fichier cms.xml avec un contenu qui ressemble à :

<?xml version="1.0" encoding="UTF-8"?>
<Context docBase="/home/cms/Ametys_CMS/application/tmp/v1_0_0/cms" debug="0" reloadable="false"/>

J'ai mis le lien direct vers l'application, mais remplacez le par le lien symbolique que vous avez déjà créé


Raphael Franchet
Expert Ametys

Offline

#7 10/07/2014 10:29:40

Gino3008
Guest
Registered: 10/07/2014
Posts: 5

Re: Problème back-office

Je vais faire ça au plus vite

Offline

#8 10/07/2014 10:57:57

Gino3008
Guest
Registered: 10/07/2014
Posts: 5

Re: Problème back-office

Impeccable !!
J'arrive enfin à atteindre la session admin back office.
Un grand merci cela fait 2 jours que je me casse la tête  lol

Mieux vaut 1 qui sait que 10 qui cherchent ..  Merci

Offline

Board footer

Powered by FluxBB