Forum Ametys

Forum de la communauté Ametys

You are not logged in.

#1 28/11/2014 11:34:30

Philippe
Guest
Registered: 28/11/2014
Posts: 5

Problème d'authentification

Bonjour,

j'ai installé la version de demo du CMS sous windows 7, tout semble OK.
J'ai ensuite installé la version de prod (toujours sous windows 7) avec un serveur tomcat et
sans apache dans un premier temps. A la première connexion, la fenetre "impossible de charger la configuration"
s'ouvre normalement mais l'authentification admin / admin échoue, la fenêtre de demande d'authentification
boucle lorsqu'on valide et le massage d'erreur apparaît (voir pièce jointe) si l'on clique sur annuler.
J'ai commencé à décompiler quelques classes pour essayer de trouver l'origine du problème mais ça risque
d'être laborieux. Auriez vous une solution à ce problème ?

Cordialement

Offline

#2 28/11/2014 11:43:59

Raphaël Franchet
Expert Team
From: Toulouse
Registered: 10/08/2010
Posts: 1,091

Re: Problème d'authentification

Bonjour,
Ametys est opensource, pas la peine de décompiler smile

Pour ré-initialiser le mot de passe de l'admin, il faut effacer le fichier qui est dans WEB-INF/data/administrator (comme indiqué dans le doc ici https://wiki.ametys.org/display/AMETYSF … +de+passe)

C'est bien admin/admin le mot de passe par défaut.

Si cela ne fonctionne pas pourrez-vous fournir une capture d'écran de la fenetre qui vous demande le login.


Raphael Franchet
Expert Ametys

Offline

#3 28/11/2014 12:59:22

Philippe
Guest
Registered: 28/11/2014
Posts: 5

Re: Problème d'authentification

Merci pour la rapidité de votre réponse Raphaël.

J'avais lu la procédure de réinitialisation du mot de passe mais ai-je zappé quelque chose dans la procédure
d'installation car je n'ai pas de répertoire data (je l'ai créé manuellement) ni administrator ?
Quoi qu'il en soit je vous ai joint l' image des fenêtres de demande d'authentification avec firefox.
Avec IE il y a un message suppémentaire : "Avertissement : ce serveur requiert que votre nom d'utilisateur et votre
mot de passe soient envoyés de façon non sécurisée etc..."
Je n'ai pas installé de base de données pour le moment. Ne serait-ce pas l'origine du problème ?

Cordialement

Offline

#4 28/11/2014 13:19:00

Raphaël Franchet
Expert Team
From: Toulouse
Registered: 10/08/2010
Posts: 1,091

Re: Problème d'authentification

Non c'est normal.
"data" n'est créé que lorsqu'on en a besoin, et là l'application n'a pas encore démarré puisqu'elle n'est pas configurée smile
et "data/administrator" n'est créé que lorsqu'on change le mot de passe ; donc vous avez bien la valeur par défaut "admin" et "admin".

Le message avec IE (et firefox met le même dans la console) vient du fait que le mot de passe n'est pas crypté et transite sur du http non sécurisé. Il faut passer Apache ou Tomcat en https pour ne plus l'avoir. Mais c'est n'est pas l'origine de votre problème.

La base de données n'a pas besoin d'exister à ce moment là.

Votre boite de dialogue me parait correcte.
Donc deux solutions:
1) soit vous ne savez pas taper "admin" deux fois smile
2) soit vous avez un problème de droits sur le système de fichiers : par exemple, lorsqu'il cherche le fichier WEB-INF/data/administrator pour voir s'il existe ; Ametys obtient un AccessDenied au système de fichier. Il est possible par exemple que vous ayez tout dézippé en lecture seule ? ou bien que l'utilisateur qui lance tomcat n'ait pas les droits. Avez-vous installé Tomcat en service ? ou le lancez-vous via la startup.bat ?
Dans tous les cas, jettez un oeil aux logs de tomcat (tomcat/logs/catalina.out) et d'Ametys (cms/WEB-INF/logs). Mais pour ce dernier si c'est un problème de droit, il n'existera pas.
Vous pouvez pour vérifier le pb de droits, passer les logs en INFO (dans WEB-INF/log4j.xml), et si "WEB-INF/logs" n'est pas créé, c'est bien ça le soucis


Raphael Franchet
Expert Ametys

Offline

#5 28/11/2014 19:13:12

Philippe
Guest
Registered: 28/11/2014
Posts: 5

Re: Problème d'authentification

Raphaël,

- Tomcat est lancé par le startup.bat en tant qu'administrateur (notre stratégie de groupe nous l'impose).
- Les logs sont bien générées (je les ai joint au message)
A priori, il ne s'agit donc pas d'un problème de droits sur le file system.
J'ai essayé avec trois navigateurs différents (IE8, Firefox version groupe Orange et opéra 26).
J'ai porté l'installation sur un serveur linux, même problème sad
Pour le moment, je ne vois pas où se trouve le problème de configuration, si c'en est un.
Je ferai quand j'aurai le temps une installation chez moi afin de voir s'il ne s'agit pas d'une question de stratégie
de groupe.
Je suis en déplacement la semaine prochaine, je vous recontacterai semaine 50. Je regarderai toutefois le forum
de temps à autre.

Bon week-end.

Offline

#6 28/11/2014 19:14:36

Philippe
Guest
Registered: 28/11/2014
Posts: 5

Re: Problème d'authentification

Deuxième log

Offline

#7 28/11/2014 22:31:58

Cédric Damioli
Ametys Product Manager
From: Toulouse
Registered: 10/08/2010
Posts: 293

Re: Problème d'authentification

Bonjour,

Je suppose que vous utilisez Tomcat 8 (d'après vos logs).
Il y a un souci avec cette version (une gestion des paramètres plus restrictive qui génère une erreur chez nous).
Un bug a été ouvert et sera résolu dans la branche 3.6 : https://issues.ametys.org/browse/CMS-5561

Vous avez la possibilité d'utiliser Tomcat 7 ?

Offline

#8 30/11/2014 12:01:06

Philippe
Guest
Registered: 28/11/2014
Posts: 5

Re: Problème d'authentification

Bonjour Cédric,

bingo, vous avez trouvé l'origine du problème !  smile
J'ai installé Tomcat 7 et j'accède à présent sans difficulté au menu d'administration.
Je vais pouvoir continuer et découvrir votre (à priori superbe) CMS.

Cordialement
Philippe

Offline

Board footer

Powered by FluxBB